Cấu hình HSRP

Một network được cung cấp tính năng High Availability nghĩa là các cơ sở hạ tầng mạng hay các server quan trọng trong network đó luôn luôn ở trong trạng thái có thể được truy cập đến vào bất kỳ thời điểm nào. Hot Standby Routing Prototocol (HSRP) là một trong những số tính năng cung cấp khả năng Redundancy ở layer 3 cho các host trong network. HSRP sẽ tối ưu hóa việc cung cấp các đường kết nối khi phát hiện một đường link bị fail và những cơ chế phục hồi sau khi ta gặp sự cố trong mạng. Topic trước đã đưa ra phần lý thuyết HSRP, Bài này mình sẽ đưa cách cấu hình HSRP, đầu tiên chúng ta hiểu 1 số tùy chọn cấu hình ví dụ priority, track, preempt… :
– Câu lệnh cấu hình trong mode interface : Standby preempt cho phép router trở thành active router khi mà độ ưu tiên của nó cao hơn tất cả các router được cấu hình HSRP khác trong 1 Hot Standby group. Cấu hình của cả router bao gồm các câu lệnh để mỗi router có thể là standby router cho router khác. Nếu bạn không sử dụng câu lệnh standby preempt router đó không thể trở thành active router.
– Cấu hình interface standby priority thiết lập độ ưu tiên cho router HSRP (mặc định priority là 100)
– Cấu hình interface : standby timers thiết lập thời gian giữa các thông điệp hello (được gọi là hello time). Hello Interval Time: Khoảng thời gian giữa hai gói tin Hello HSRP thành công từ một router. Thời gian này là 3 giây. Hold Interval Time: khoảng thời gian giữa hai gói tin hello được nhận và giả định rằng sender router bị fail. Mặc định là 10 giây. Nếu bạn quyết định thay đổi giá trị mặc định , bạn phải cấu hình mỗi router sử dụng hello time và hold time tương tự.
– Câu lệnh standby track cho phép bạn chỉ định 1 interface khác trên router cho việc sử ly HSRP mục đích để giám sát việc thay đổi độ ưu tiên HSRP cho 1 nhóm. Nếu 1 interface bị down, priority HSRP sẽ được giảm. Có nghĩa là router HSRP khác với độ ưu tiên cao hơn có thể trở thành active router nếu router đó có standby preempt được enable.
– Câu lệnh cấu hình standby authentication thiết lập sự mã hóa chuổi, giá trị của nó là 8 kí tự được giải mã mà tổng hợp nên thành thông điệp HSRP muticast. Câu lệnh này là tùy chọn. Nếu bạn chọn nó, mỗi cấu hình HSRP trong 1 nhóm sẽ được sử dụng cùng 1 chỗi để mỗi router có thể xác thực nguồn của thông điệp HSRP mà nó nhận.
Mô hình mạng:

Click the image to open in full size.

Cấu hình :
Các bạn tự cấu hình định tuyến giữa các switch layer 3

Ciscozine_1#

interface FastEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk

interface Vlan101
ip address 172.16.101.2 255.255.255.0
standby 1 ip 172.16.101.1
standby 1 priority 150
standby 1 preempt
standby 1 track FastEthernet0/3 55
standby 1 authentication C3s_101
no shutdown

interface Vlan102
ip address 172.16.102.2 255.255.255.0
standby 2 ip 172.16.102.1
standby 2 preempt
standby 2 track FastEthernet0/3
standby 2 authentication C3s_102
no shutdown

interface Vlan103
ip address 172.16.103.2 255.255.255.0
standby 3 ip 172.16.103.1
standby 3 priority 150
standby 3 preempt
standby 3 track FastEthernet0/3 50
standby 3 authentication C3s_103
no shutdown

Cấu hình switch layer 3 Ciscozine_2:
Ciscozine_2#

interface FastEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk

interface Vlan101
ip address 172.16.101.3 255.255.255.0
standby 1 ip 172.16.101.1
standby 1 preempt
standby 1 track FastEthernet0/3
standby 1 authentication C3s_101
no shutdown

interface Vlan102
ip address 172.16.102.3 255.255.255.0
standby 2 ip 172.16.102.1
standby 2 priority 150
standby 2 preempt
standby 2 track FastEthernet0/3 60
standby 2 authentication C3s_102
no shutdown

interface Vlan103
ip address 172.16.103.3 255.255.255.0
standby 3 ip 172.16.103.1
standby 3 preempt
standby 3 track FastEthernet0/3
standby 3 authentication C3s_103
no shutdown

switchport trunk encapsulation dot1q
switchport mode trunk
// Thiết lập trunking giữa các switch

Switch layer 3 Ciscozine_1 là thiết bị chính cho VLAN 101 và VLAN 103 và là thiết bị dự phòng cho VLAN 101 và VLAN 103. Cấu hình này cho phép sự cân bằng tải trong mạng.
Nếu cổng FastEthenet 0/3 trên thiết bị chính bị đứt, thiết bị dự phòng sẽ trở thành thiết bị chính, trừ khi FastEthenet 0/3 trên thiết bị backup cũng fail hoặc FastEthenet 0/3 trên thiết bị chính sẽ được active trở lại. Điều này được mô phỏng ở bên dưới :

Click the image to open in full size.

Nếu cổng FastEthernet0/3 down, Ciscozine_2 sẽ trở thành active router cho VLAN 101 và VLAN 103

 

Click the image to open in full size.

Nếu cổng FastEthernet0/3 của Ciscozine_1 và cổng FastEthernet0/3 của Ciscozine_2 bị down, active router cho VLAN 101 và VLAN 103 sẽ là Ciscozine_1.

Giải thích:
• Địa chỉ Ip standby là 172.16.103.1
• HSRP ưu tiên các router với ưu tiên cao hơn, và nếu nó là như nhau, nó sẽ ưu tiên các địa chỉ IP cao hơn. Ciscozine_1 là active router bởi vì nó có một ưu tiên là 150 trong khi Ciscozine_2 đã ưu tiên mặc định của 100. Cả 2 đều có câu lệnh preempt để trở thành active router khi độ ưu tiên của nó cao hơn tất cả các router cấu hình HSRP khác trong 1 Hot Standby group.
• Interface tracking cho phép độ ưu tiên của một nhóm standby router sẽ tự động thay đổi dựa trên sự sẵn có của interface router. Khi một interface down, độ ưu tiên của router HSRP sẽ giảm. Nếu FastEthernet0/3 của Ciscozine_1, độ ưu tiên HSRP giảm đi 50 và do đó, ưu tiên sẽ là 100 (150-50). Sau đó là cả 2 router đều sẽ có cùng độ ưu tiên là 100 và Ciscozine_2 sẽ là active router bởi vì nó có địa chỉ ip cao hơn. Nếu FastEthernet 0 / 3 của Ciscozine_2 down, độ ưu tiên của Ciscozine_2 sẽ được giảm đi của 10 giá trị mặc định và do đó sẽ được ưu tiên 90 (100-10). Sau đó, active router sẽ là Ciscozine_1 một lần nữa!
• authentication key là C3s_103 và nó được gửi dưới dạng clear text. Từ IOS version 12.3(2)T nó có thể gửi key sử dụng MD5.
Tương tự áp dụng với VLAN 101 và VLAN 102.

Văn Phú (theo kenhgiaiphap)